9
Août
08

Activez le PHP5 pour WordPress!





Depuis quelques temps, je commençais à avoir pas mal de problèmes d’incompatibilités avec un certain nombre de plugins sous WordPress. Soit j’avais des erreurs 500, soit la page de configuration du plugin restait vide, soit il était inopérant bien qu’il semblait fonctionner correctement au premier abord. En fait, tout ceci est dû à la version du PHP utilisée. Par défaut chez mon hébergeur, c’est du PHP 4. J’ai activé le PHP 5 et oh miracle, le plugin de backup fonctionne de nouveau. Pareil pour le crawl rate tracker et le google xml sitemaps!

Bien entendu, vous vous demandez sûrement comment j’ai fait pour activer le php 5 sur mon hébergement. Il suffit d’ajouter la ligne suivante dans le .htaccess à la racine du blog :

AddType x-mapp-php5 .php

Et voilà, fini les bugs avec un certain nombre de plugins, c’est pas beau ça?





2 commentaires pour “Activez le PHP5 pour WordPress!”
  1. Gilles dit :

    Ha tu savais pas ? LOL
    PHP5 + MySQL 5 hein 😉
    Faut être moderne 🙂
    JE te dis pas la diff : entre 5 plugins maxi avec PHP4 et heu une tonne en PHP5 !

  2. Olivier dit :

    J’avais plus de 5 plugins avec PHP4 mais bon, c’est 1&1 aussi qui active par défaut le PHP4…



L'autre monde | Thème liquide par Olivier